Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#911 closed task (invalid)

i2pSNARK fatal storage error

Reported by: DISABLED Owned by: zzz
Priority: obsolete Milestone: 0.9.5
Component: apps/i2psnark Version: 0.9.4
Keywords: Cc:
Parent Tickets: Sensitive: no

Description (last modified by killyourtv)

I keep running into an error on something I'm seeding, and was looking for some help. I am successful seeding a couple other larger files right now as well.

I keep seeing this message that stops the torrent as "complete" after a short time with little or no information actually having been uploaded.

    Fatal storage error: Stopping torrent [redacted]

    Error reading the storage (piece 694*) for [redacted]: java.io.FileNotFoundException: [redacted]

    Piece number listed as in error is different each time I click start after it stops itself

I have what looks like 5 or 6 people who want the file (via postman tracker as primary, diftracker and welterde as alternates), and if possible would like to fix the issue with out resorting to nuking the listing and reuploading.

Thanks for the help.

Win7 Home Premium SP1 64 Bit fully updated Running in Firefox

i2p is installed on main windows partition while torrents/data are on separate for media storage. Both are NTFS.

Reddit post - http://www.reddit.com/r/i2p/comments/1blr2k/help_needed_with_i2psnark_seeding_error/

http://i.imgur.com/dT01pls.png (Screenshot of the error reproduced this afternoon)

Information from I2P Router Logs:

I2P version: 0.9.5-0
Java version: Oracle Corporation 1.7.0_17 (Java(TM) SE Runtime Environment 1.7.0_17-b02)
Wrapper version: 3.5.15
Server version: 6.1.26
Servlet version: Jasper JSP 2.1 Engine
Platform: Windows 7 x86 6.1
Processor: Core i5/i7 (45nm) (corei)
Jbigi: Locally optimized native BigInteger library loaded from file
Encoding: Cp1252
Charset: windows-1252

Router Logs:
File location: C:\ProgramData\Application Data\i2p\logs\log-router-0.txt

    4/4/13 3:18:46 PM ERROR [D@9N7gNU 269] .klomp.snark.PeerConnectionOut: Error sending to AwMD@9N7gNU 269
         java.lang.RuntimeException: Error reading the storage (piece 1270) for Doctor Who S07E06 The Bells of Saint John: java.io.FileNotFoundException: D:\Media\Doctor Who S07E06 The Bells of Saint John (Access is denied)
         at org.klomp.snark.PeerCoordinator.gotRequest(PeerCoordinator.java:926)
         at org.klomp.snark.PeerState.loadData(PeerState.java:250)
         at org.klomp.snark.Message.sendMessage(Message.java:93)
         at org.klomp.snark.PeerConnectionOut.run(PeerConnectionOut.java:180)
         at java.lang.Thread.run(Unknown Source)
         at net.i2p.util.I2PThread.run(I2PThread.java:85)
         Caused by: java.io.FileNotFoundException: D:\Media\Doctor Who S07E06 The Bells of Saint John (Access is denied)
         at java.io.RandomAccessFile.open(Native Method)
         at java.io.RandomAccessFile.<init>(Unknown Source)
         at org.klomp.snark.Storage.openRAF(Storage.java:1198)
         at org.klomp.snark.Storage.openRAF(Storage.java:1194)
         at org.klomp.snark.Storage.checkRAF(Storage.java:1190)
         at org.klomp.snark.Storage.getUncheckedPiece(Storage.java:1143)
         at org.klomp.snark.Storage.getPiece(Storage.java:984)
         at org.klomp.snark.PeerCoordinator.gotRequest(PeerCoordinator.java:915)
         ... 5 more
    4/4/13 3:18:46 PM ERROR [D@9N7gNU 269] rg.klomp.snark.PeerCoordinator: Error reading the storage (piece 1270) for Doctor Who S07E06 The Bells of Saint John: java.io.FileNotFoundException: D:\Media\Doctor Who S07E06 The Bells of Saint John (Access is denied)
         java.io.FileNotFoundException: D:\Media\Doctor Who S07E06 The Bells of Saint John (Access is denied)
         at java.io.RandomAccessFile.open(Native Method)
         at java.io.RandomAccessFile.<init>(Unknown Source)
         at org.klomp.snark.Storage.openRAF(Storage.java:1198)
         at org.klomp.snark.Storage.openRAF(Storage.java:1194)
         at org.klomp.snark.Storage.checkRAF(Storage.java:1190)
         at org.klomp.snark.Storage.getUncheckedPiece(Storage.java:1143)
         at org.klomp.snark.Storage.getPiece(Storage.java:984)
         at org.klomp.snark.PeerCoordinator.gotRequest(PeerCoordinator.java:915)
         at org.klomp.snark.PeerState.loadData(PeerState.java:250)
         at org.klomp.snark.Message.sendMessage(Message.java:93)
         at org.klomp.snark.PeerConnectionOut.run(PeerConnectionOut.java:180)
         at java.lang.Thread.run(Unknown Source)
         at net.i2p.util.I2PThread.run(I2PThread.java:85)
    4/4/13 3:13:37 PM ERROR [D@PpuAFN 232] .klomp.snark.PeerConnectionOut: Error sending to AwMD@PpuAFN 232
         java.lang.RuntimeException: Error reading the storage (piece 2873) for Zero Dark Thirty: java.io.FileNotFoundException: D:\Media\Zero Dark Thirty (Access is denied)
         at org.klomp.snark.PeerCoordinator.gotRequest(PeerCoordinator.java:926)
         at org.klomp.snark.PeerState.loadData(PeerState.java:250)
         at org.klomp.snark.Message.sendMessage(Message.java:93)
         at org.klomp.snark.PeerConnectionOut.run(PeerConnectionOut.java:180)
         at java.lang.Thread.run(Unknown Source)
         at net.i2p.util.I2PThread.run(I2PThread.java:85)
         Caused by: java.io.FileNotFoundException: D:\Media\Zero Dark Thirty (Access is denied)
         at java.io.RandomAccessFile.open(Native Method)
         at java.io.RandomAccessFile.<init>(Unknown Source)
         at org.klomp.snark.Storage.openRAF(Storage.java:1198)
         at org.klomp.snark.Storage.openRAF(Storage.java:1194)
         at org.klomp.snark.Storage.checkRAF(Storage.java:1190)
         at org.klomp.snark.Storage.getUncheckedPiece(Storage.java:1143)
         at org.klomp.snark.Storage.getPiece(Storage.java:984)
         at org.klomp.snark.PeerCoordinator.gotRequest(PeerCoordinator.java:915)
         ... 5 more
    4/4/13 3:13:37 PM ERROR [D@PpuAFN 232] rg.klomp.snark.PeerCoordinator: Error reading the storage (piece 2873) for Zero Dark Thirty: java.io.FileNotFoundException: D:\Media\Zero Dark Thirty (Access is denied)
         java.io.FileNotFoundException: D:\Media\Zero Dark Thirty (Access is denied)
         at java.io.RandomAccessFile.open(Native Method)
         at java.io.RandomAccessFile.<init>(Unknown Source)
         at org.klomp.snark.Storage.openRAF(Storage.java:1198)
         at org.klomp.snark.Storage.openRAF(Storage.java:1194)
         at org.klomp.snark.Storage.checkRAF(Storage.java:1190)
         at org.klomp.snark.Storage.getUncheckedPiece(Storage.java:1143)
         at org.klomp.snark.Storage.getPiece(Storage.java:984)
         at org.klomp.snark.PeerCoordinator.gotRequest(PeerCoordinator.java:915)
         at org.klomp.snark.PeerState.loadData(PeerState.java:250)
         at org.klomp.snark.Message.sendMessage(Message.java:93)
         at org.klomp.snark.PeerConnectionOut.run(PeerConnectionOut.java:180)
         at java.lang.Thread.run(Unknown Source)
         at net.i2p.util.I2PThread.run(I2PThread.java:85)
    4/4/13 3:10:29 PM ERROR [D@nqlB3~ 214] .klomp.snark.PeerConnectionOut: Error sending to AwMD@nqlB3~ 214
         java.lang.RuntimeException: Error reading the storage (piece 497) for Doctor Who S07E06 The Bells of Saint John: java.io.FileNotFoundException: D:\Media\Doctor Who S07E06 The Bells of Saint John (Access is denied)
         at org.klomp.snark.PeerCoordinator.gotRequest(PeerCoordinator.java:926)
         at org.klomp.snark.PeerState.loadData(PeerState.java:250)
         at org.klomp.snark.Message.sendMessage(Message.java:93)
         at org.klomp.snark.PeerConnectionOut.run(PeerConnectionOut.java:180)
         at java.lang.Thread.run(Unknown Source)
         at net.i2p.util.I2PThread.run(I2PThread.java:85)
         Caused by: java.io.FileNotFoundException: D:\Media\Doctor Who S07E06 The Bells of Saint John (Access is denied)
         at java.io.RandomAccessFile.open(Native Method)
         at java.io.RandomAccessFile.<init>(Unknown Source)
         at org.klomp.snark.Storage.openRAF(Storage.java:1198)
         at org.klomp.snark.Storage.openRAF(Storage.java:1194)
         at org.klomp.snark.Storage.checkRAF(Storage.java:1190)
         at org.klomp.snark.Storage.getUncheckedPiece(Storage.java:1143)
         at org.klomp.snark.Storage.getPiece(Storage.java:984)
         at org.klomp.snark.PeerCoordinator.gotRequest(PeerCoordinator.java:915)
         ... 5 more
    4/4/13 3:10:29 PM ERROR [D@nqlB3~ 214] rg.klomp.snark.PeerCoordinator: Error reading the storage (piece 497) for Doctor Who S07E06 The Bells of Saint John: java.io.FileNotFoundException: D:\Media\Doctor Who S07E06 The Bells of Saint John (Access is denied)
         java.io.FileNotFoundException: D:\Media\Doctor Who S07E06 The Bells of Saint John (Access is denied)
         at java.io.RandomAccessFile.open(Native Method)
         at java.io.RandomAccessFile.<init>(Unknown Source)
         at org.klomp.snark.Storage.openRAF(Storage.java:1198)
         at org.klomp.snark.Storage.openRAF(Storage.java:1194)
         at org.klomp.snark.Storage.checkRAF(Storage.java:1190)
         at org.klomp.snark.Storage.getUncheckedPiece(Storage.java:1143)
         at org.klomp.snark.Storage.getPiece(Storage.java:984)
         at org.klomp.snark.PeerCoordinator.gotRequest(PeerCoordinator.java:915)
         at org.klomp.snark.PeerState.loadData(PeerState.java:250)
         at org.klomp.snark.Message.sendMessage(Message.java:93)
         at org.klomp.snark.PeerConnectionOut.run(PeerConnectionOut.java:180)
         at java.lang.Thread.run(Unknown Source)
         at net.i2p.util.I2PThread.run(I2PThread.java:85)
    4/4/13 3:08:18 PM ERROR [D@PpuAFN 133] .klomp.snark.PeerConnectionOut: Error sending to AwMD@PpuAFN 133
         java.lang.RuntimeException: Error reading the storage (piece 2873) for Zero Dark Thirty: java.io.FileNotFoundException: D:\Media\Zero Dark Thirty (Access is denied)
         at org.klomp.snark.PeerCoordinator.gotRequest(PeerCoordinator.java:926)
         at org.klomp.snark.PeerState.loadData(PeerState.java:250)
         at org.klomp.snark.Message.sendMessage(Message.java:93)
         at org.klomp.snark.PeerConnectionOut.run(PeerConnectionOut.java:180)
         at java.lang.Thread.run(Unknown Source)
         at net.i2p.util.I2PThread.run(I2PThread.java:85)
         Caused by: java.io.FileNotFoundException: D:\Media\Zero Dark Thirty (Access is denied)
         at java.io.RandomAccessFile.open(Native Method)
         at java.io.RandomAccessFile.<init>(Unknown Source)
         at org.klomp.snark.Storage.openRAF(Storage.java:1198)
         at org.klomp.snark.Storage.openRAF(Storage.java:1194)
         at org.klomp.snark.Storage.checkRAF(Storage.java:1190)
         at org.klomp.snark.Storage.getUncheckedPiece(Storage.java:1143)
         at org.klomp.snark.Storage.getPiece(Storage.java:984)
         at org.klomp.snark.PeerCoordinator.gotRequest(PeerCoordinator.java:915)
         ... 5 more
    4/4/13 3:08:18 PM ERROR [D@PpuAFN 133] rg.klomp.snark.PeerCoordinator: Error reading the storage (piece 2873) for Zero Dark Thirty: java.io.FileNotFoundException: D:\Media\Zero Dark Thirty (Access is denied)
         java.io.FileNotFoundException: D:\Media\Zero Dark Thirty (Access is denied)
         at java.io.RandomAccessFile.open(Native Method)
         at java.io.RandomAccessFile.<init>(Unknown Source)
         at org.klomp.snark.Storage.openRAF(Storage.java:1198)
         at org.klomp.snark.Storage.openRAF(Storage.java:1194)
         at org.klomp.snark.Storage.checkRAF(Storage.java:1190)
         at org.klomp.snark.Storage.getUncheckedPiece(Storage.java:1143)
         at org.klomp.snark.Storage.getPiece(Storage.java:984)
         at org.klomp.snark.PeerCoordinator.gotRequest(PeerCoordinator.java:915)
         at org.klomp.snark.PeerState.loadData(PeerState.java:250)
         at org.klomp.snark.Message.sendMessage(Message.java:93)
         at org.klomp.snark.PeerConnectionOut.run(PeerConnectionOut.java:180)
         at java.lang.Thread.run(Unknown Source)
         at net.i2p.util.I2PThread.run(I2PThread.java:85)
    4/4/13 2:57:47 PM WARN [Addressbook ] .naming.BlockfileNamingService: The hosts database was not closed cleanly or is still open by another process

Subtickets

Change History (2)

comment:1 Changed 7 years ago by Eche|on

Priority: majorobsolete
Resolution: invalid
Status: newclosed
Type: defecttask

Moin

It says clearly in the log:
S07E06 The Bells of Saint John: java.io.FileNotFoundException??: D:\Media\Doctor Who S07E06 The Bells of Saint John (Access is denied)

Access denied - your system does not allow I2Psnark to read the files. There is nothing we can do about this.

echelon

comment:2 Changed 6 years ago by killyourtv

Description: modified (diff)
Note: See TracTickets for help on using tickets.