Opened 9 years ago

Closed 9 years ago

#92 closed defect (wontfix)

Pipe closed / UPnP timeout

Reported by: anonymous Owned by:
Priority: minor Milestone:
Component: router/transport Version:
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

I2P version: 0.8-0
Java version: Sun Microsystems Inc. 1.6.0_21 (Java™ SE Runtime Environment 1.6.0_21-b06)
Platform: Windows XP x86 5.1
Processor: uninitialized (pentium3)
Jbigi: Locally optimized native BigInteger? library loaded from the library path
Encoding: Cp1252

Berichte der Kritischen Ereignisse
Router Berichte (ändere)
Ort der Datei: C:\Programme\i2p\logs\log-router-1.txt

10:16:58.365 FEHLER [2CP Reader 3] ent.ClientMessageEventListener?: Error occurred net.i2p.data.DataFormatException?: Not enough bytes for the field at net.i2p.data.DataHelper?.readLong(DataHelper?.java:402) at net.i2p.data.i2cp.SessionId?.readBytes(SessionId?.java:41) at net.i2p.data.i2cp.DestroySessionMessage?.doReadMessage(DestroySessionMessage?.java:44) at net.i2p.data.i2cp.I2CPMessageImpl.readMessage(I2CPMessageImpl.java:74) at net.i2p.data.i2cp.I2CPMessageHandler.readMessage(I2CPMessageHandler.java:45) at net.i2p.data.i2cp.I2CPMessageReader$I2CPMessageReaderRunner.run(I2CPMessageReader.java:153) at java.lang.Thread.run(Unknown Source) at net.i2p.util.I2PThread.run(I2PThread.java:77) net.i2p.data.i2cp.I2CPMessageException: Unable to load the message data at net.i2p.data.i2cp.DestroySessionMessage?.doReadMessage(DestroySessionMessage?.java:46) at net.i2p.data.i2cp.I2CPMessageImpl.readMessage(I2CPMessageImpl.java:74) at net.i2p.data.i2cp.I2CPMessageHandler.readMessage(I2CPMessageHandler.java:45) at net.i2p.data.i2cp.I2CPMessageReader$I2CPMessageReaderRunner.run(I2CPMessageReader.java:153) at java.lang.Thread.run(Unknown Source) at net.i2p.util.I2PThread.run(I2PThread.java:77)
10:16:58.365 FEHLER [ent Writer 2] net.i2p.client.I2PSessionImpl2: [16822]: cause java.io.IOException: Pipe closed at java.io.PipedInputStream?.checkStateForReceive(Unknown Source) at java.io.PipedInputStream?.receive(Unknown Source) at java.io.PipedOutputStream?.write(Unknown Source) at java.io.OutputStream?.write(Unknown Source) at net.i2p.data.i2cp.I2CPMessageImpl.writeMessage(I2CPMessageImpl.java:112) at net.i2p.client.ClientWriterRunner?.run(ClientWriterRunner?.java:69) at java.lang.Thread.run(Unknown Source) at net.i2p.util.I2PThread.run(I2PThread.java:77)
10:16:58.365 FEHLER [ent Writer 2] net.i2p.client.I2PSessionImpl2: [16822]: Error occurred: Error writing out the message - Pipe closed
09:32:02.380 FEHLER [NotifySocket?] org.cybergarage.util.Debug : org.cybergarage.xml.ParserException?: java.net.SocketTimeoutException?: connect timed out at org.cybergarage.xml.Parser.parse(Parser.java:65) at org.cybergarage.upnp.ControlPoint?.addDevice(ControlPoint?.java:228) at org.cybergarage.upnp.ControlPoint?.notifyReceived(ControlPoint?.java:477) at org.cybergarage.upnp.ssdp.SSDPNotifySocket.run(SSDPNotifySocket.java:112) at java.lang.Thread.run(Unknown Source) Caused by: java.net.SocketTimeoutException?: connect timed out at java.net.PlainSocketImpl?.socketConnect(Native Method) at java.net.PlainSocketImpl?.doConnect(Unknown Source) at java.net.PlainSocketImpl?.connectToAddress(Unknown Source) at java.net.PlainSocketImpl?.connect(Unknown Source) at java.net.SocksSocketImpl?.connect(Unknown Source) at java.net.Socket.connect(Unknown Source) at sun.net.NetworkClient?.doConnect(Unknown Source) at sun.net.www.http.HttpClient?.openServer(Unknown Source) at sun.net.www.http.HttpClient?.openServer(Unknown Source) at sun.net.www.http.HttpClient?.(Unknown Source) at sun.net.www.http.HttpClient?.New(Unknown Source) at sun.net.www.http.HttpClient?.New(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection.plainConnect(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection.connect(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source) at org.cybergarage.xml.Parser.parse(Parser.java:55) … 4 more
09:32:02.380 FEHLER [NotifySocket?] org.cybergarage.util.Debug : NOTIFY * HTTP/1.1 Host:239.255.255.250:1900 NT:upnp:rootdevice NTS:ssdp:alive Location:http://192.168.2.100:2869/upnphost/udhisapi.dll?content=uuid:a8420979-3a0b-4a21-ae28-37221416c0f5 USN:uuid:a8420979-3a0b-4a21-ae28-37221416c0f5::upnp:rootdevice Cache-Control:max-age=900 Server:Microsoft-Windows-NT/5.1 UPnP/1.0 UPnP-Device-Host/1.0 OPT:"http://schemas.upnp.org/upnp/1/0/"; ns=01 01-NLS:5b0902ae924b6316d1e8bf74fe5ac24c
09:31:59.443 FEHLER [NotifySocket?] org.cybergarage.util.Debug : org.cybergarage.xml.ParserException?: java.net.SocketTimeoutException?: connect timed out at org.cybergarage.xml.Parser.parse(Parser.java:65) at org.cybergarage.upnp.ControlPoint?.addDevice(ControlPoint?.java:228) at org.cybergarage.upnp.ControlPoint?.notifyReceived(ControlPoint?.java:477) at org.cybergarage.upnp.ssdp.SSDPNotifySocket.run(SSDPNotifySocket.java:112) at java.lang.Thread.run(Unknown Source) Caused by: java.net.SocketTimeoutException?: connect timed out at java.net.PlainSocketImpl?.socketConnect(Native Method) at java.net.PlainSocketImpl?.doConnect(Unknown Source) at java.net.PlainSocketImpl?.connectToAddress(Unknown Source) at java.net.PlainSocketImpl?.connect(Unknown Source) at java.net.SocksSocketImpl?.connect(Unknown Source) at java.net.Socket.connect(Unknown Source) at sun.net.NetworkClient?.doConnect(Unknown Source) at sun.net.www.http.HttpClient?.openServer(Unknown Source) at sun.net.www.http.HttpClient?.openServer(Unknown Source) at sun.net.www.http.HttpClient?.(Unknown Source) at sun.net.www.http.HttpClient?.New(Unknown Source) at sun.net.www.http.HttpClient?.New(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection.plainConnect(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection.connect(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source) at org.cybergarage.xml.Parser.parse(Parser.java:55) … 4 more
09:31:59.443 FEHLER [NotifySocket?] org.cybergarage.util.Debug : NOTIFY * HTTP/1.1 Host:239.255.255.250:1900 NT:upnp:rootdevice NTS:ssdp:alive Location:http://192.168.2.100:2869/upnphost/udhisapi.dll?content=uuid:a8420979-3a0b-4a21-ae28-37221416c0f5 USN:uuid:a8420979-3a0b-4a21-ae28-37221416c0f5::upnp:rootdevice Cache-Control:max-age=900 Server:Microsoft-Windows-NT/5.1 UPnP/1.0 UPnP-Device-Host/1.0 OPT:"http://schemas.upnp.org/upnp/1/0/"; ns=01 01-NLS:5b0902ae924b6316d1e8bf74fe5ac24c

Subtickets

Change History (1)

comment:1 Changed 9 years ago by zzz

Component: api/datarouter/transport
Priority: majorminor
Resolution: wontfix
Status: newclosed
Summary: bugs bugs bugsPipe closed / UPnP timeout

The first is 'pipe closed' which is caused by the app going away.

The second is a UPnP timeout which is harmless.

Note: See TracTickets for help on using tickets.