Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#920 closed defect (fixed)

Unable to Access http://127.0.0.1:7658 under Win8Pro: i2p 0.9.5-11

Reported by: DISABLED Owned by:
Priority: blocker Milestone: 0.9.6
Component: apps/jetty Version: 0.9.5
Keywords: no eepsite access Cc: killyourtv
Parent Tickets: Sensitive: no

Description (last modified by zzz)

History:

  1. Clean install of 0.9.5-0 under Win8Pro, no plugins installed, everything left at i2p defaults
  2. Updated to -9, unable to access http://127.0.0.1:7658/, Susi not working, snark working
  3. Updated to -11, unable to access http://127.0.0.1:7658/, Susi working, snark working

I'm running Oracle Java, r21.

Below is a copy of the latest from my wrapper.txt:

2013/04/20 05:41:43 | INFO: Update installed
2013/04/20 05:41:43 | INFO: Restarting after update
2013/04/20 05:41:45 | on_exit trigger matched.  Restarting the JVM.  (Exit code: 4)
2013/04/20 05:42:01 | Launching a JVM...
2013/04/20 05:42:01 | WrapperManager: Initializing...
2013/04/20 05:42:01 | Starting I2P 0.9.5-11
2013/04/20 05:42:02 | INFO: Native CPUID library jcpuid-x86-windows loaded from file
2013/04/20 05:42:02 | INFO: Locally optimized native BigInteger library loaded from file
2013/04/20 05:42:02 | INFO: Jetty 7.6.10.v20130312 logging to I2P logs using class org.eclipse.jetty.server.Server
2013/04/20 05:42:03 | 2013-04-20 05:42:03.219:INFO:oejs.Server:jetty-7.6.10.v20130312
2013/04/20 05:42:59 | CRIT  [er (eepsite)] uter.startup.LoadClientAppsJob: Error starting up the client class net.i2p.jetty.JettyStart
2013/04/20 05:42:59 | java.lang.reflect.InvocationTargetException
2013/04/20 05:42:59 | 	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
2013/04/20 05:42:59 | 	at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
2013/04/20 05:42:59 | 	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
2013/04/20 05:42:59 | 	at java.lang.reflect.Constructor.newInstance(Unknown Source)
2013/04/20 05:42:59 | 	at net.i2p.router.startup.LoadClientAppsJob$RunApp.run(LoadClientAppsJob.java:270)
2013/04/20 05:42:59 | 	at java.lang.Thread.run(Unknown Source)
2013/04/20 05:42:59 | 	at net.i2p.util.I2PThread.run(I2PThread.java:85)
2013/04/20 05:42:59 | Caused by: java.lang.ClassNotFoundException: org.mortbay.jetty.Server
2013/04/20 05:42:59 | 	at java.net.URLClassLoader$1.run(Unknown Source)
2013/04/20 05:42:59 | 	at java.net.URLClassLoader$1.run(Unknown Source)
2013/04/20 05:42:59 | 	at java.security.AccessController.doPrivileged(Native Method)
2013/04/20 05:42:59 | 	at java.net.URLClassLoader.findClass(Unknown Source)
2013/04/20 05:42:59 | 	at java.lang.ClassLoader.loadClass(Unknown Source)
2013/04/20 05:42:59 | 	at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
2013/04/20 05:42:59 | 	at java.lang.ClassLoader.loadClass(Unknown Source)
2013/04/20 05:42:59 | 	at org.eclipse.jetty.util.Loader.loadClass(Loader.java:100)
2013/04/20 05:42:59 | 	at org.eclipse.jetty.xml.XmlConfiguration$JettyXmlConfiguration.nodeClass(XmlConfiguration.java:354)
2013/04/20 05:42:59 | 	at org.eclipse.jetty.xml.XmlConfiguration$JettyXmlConfiguration.configure(XmlConfiguration.java:332)
2013/04/20 05:42:59 | 	at org.eclipse.jetty.xml.XmlConfiguration.configure(XmlConfiguration.java:296)
2013/04/20 05:42:59 | 	at net.i2p.jetty.JettyStart.parseArgs(JettyStart.java:82)
2013/04/20 05:42:59 | 	at net.i2p.jetty.JettyStart.<init>(JettyStart.java:60)
2013/04/20 05:42:59 | 	... 7 more

Subtickets

Change History (3)

comment:1 Changed 7 years ago by zzz

Cc: killyourtv added
Component: unspecifiedapps/jetty
Description: modified (diff)
Priority: minorblocker
  • Susimail was fixed in -10
  • Due to bug #919 , when you originally installed I2P 0.9.5, the clients.config line:

clientApp.3.args="eepsite/jetty.xml"

was not correctly converted to

clientApp.3.args="C:\\full\path\to\%appdir%\eepsite/jetty.xml"

so it was using the installation $I2P\eepsite dir instead.

  • After the upgrade to 0.9.5-9, the %appdir%\eepsite\jetty.xml was migrated to Jetty 7. However the reference files in $I2P\eepsite were not migrated (the new reference files are in $I2P\jetty7)
  • clients.config now points to a non-working eepsite\jetty.xml file

The fix is to manually specify the full path to %appdir%\jetty.xml in clients.config, either by editing that file or by clicking the edit button on /configclients.jsp in the router console.

We'll have to investigate how to communicate this to the users, and whether to add some sort of automatic recovery code in the 0.9.6 release.

The problem is that some people may have started setting up their eepsite in the "wrong" place. What to do about that.

comment:2 Changed 7 years ago by zzz

Resolution: fixed
Status: newclosed

Fixed, see #919 for more info.

If you are running Windows and first installed I2P with version 0.9.5, see important information on manual fixes required at http://www.i2p2.de/ticket919 or http://www.i2p2.i2p/ticket919 .

comment:3 Changed 7 years ago by DISABLED

Thank you, zzz, for all your effort in finding and fixing this issue.

Implemented the changes, and all is working perfectly on -12.

Best regards, PrivacyHawk?

Note: See TracTickets for help on using tickets.