Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#929 closed defect (invalid)

i2ptunnel and routerconsole lag when we load too many things at a time

Reported by: guest Owned by:
Priority: minor Milestone:
Component: apps/i2ptunnel Version: 0.9.5
Keywords: Cc:
Parent Tickets:

Description

To reproduce the problem, try pushing "Развернуть все изоображения" button in this thread: http://hiddenchan.i2p/a/res/1234.html

While i2ptunnel trying to load all of these pictures and deliver them to the browser, routerconsole is unable to load at all, and i2ptunnel does not load content from other eepsites if we have them opening (i suggest implementation of priorities of some kind).

Also, CPU does not get very overloaded, so unsufficent resources is surely not the reason.

Subtickets

Change History (3)

comment:1 Changed 6 years ago by zzz

I'm not sure this is an I2P problem. We use different thread pools for the console and i2ptunnel.

Are you sure it isn't caused by browser limits? Browswers, of course, have limits on the number of active requests, and may have different limits for direct and for proxied requests.

Would you please retry your tests using different browsers for the eepsite and the console?

comment:2 Changed 6 years ago by guest

  • Resolution set to invalid
  • Status changed from new to closed

Strange... but yes, seems to be opera problem (feature?)

comment:3 Changed 6 years ago by guest

and we can also see the reason in opera:config
Max Connections Total = 64

Note: See TracTickets for help on using tickets.