Opened 6 years ago

Closed 6 years ago

#930 closed defect (fixed)

upnp addportmapping

Reported by: guest Owned by: zzz
Priority: minor Milestone: 0.9.6
Component: router/transport Version: 0.9.5
Keywords: Cc:
Parent Tickets:

Description

14/05/13 00:14:33 ↓↓↓ 3 similar messages omitted ↓↓↓
14/05/13 00:14:17 ERROR [t Opener 265] net.i2p.router.transport.UPnP : Couldn't find AddPortMapping? action!
14/05/13 00:14:12 ERROR [t Opener 265] net.i2p.router.transport.UPnP : Couldn't find AddPortMapping? action!
14/05/13 00:05:35 ERROR [t Opener 264] net.i2p.router.transport.UPnP : Couldn't find AddPortMapping? action!
14/05/13 00:05:30 ↓↓↓ 3 similar messages omitted ↓↓↓
14/05/13 00:05:14 ERROR [t Opener 264] net.i2p.router.transport.UPnP : Couldn't find AddPortMapping? action!
13/05/13 23:54:06 ↓↓↓ 2 similar messages omitted ↓↓↓
13/05/13 23:53:56 ERROR [t Opener 263] net.i2p.router.transport.UPnP : Couldn't find AddPortMapping? action!
13/05/13 23:53:50 ↓↓↓ 1 similar message omitted ↓↓↓
13/05/13 23:53:45 ERROR [t Opener 263] net.i2p.router.transport.UPnP : Couldn't find AddPortMapping? action!
13/05/13 23:47:21 ↓↓↓ 2 similar messages omitted ↓↓↓
13/05/13 23:47:11 ERROR [t Opener 262] net.i2p.router.transport.UPnP : Couldn't find AddPortMapping? action!
13/05/13 23:47:05 ↓↓↓ 1 similar message omitted ↓↓↓
13/05/13 23:47:00 ERROR [t Opener 262] net.i2p.router.transport.UPnP : Couldn't find AddPortMapping? action!
13/05/13 23:37:08 ↓↓↓ 1 similar message omitted ↓↓↓
13/05/13 23:37:02 ERROR [t Opener 261] net.i2p.router.transport.UPnP : Couldn't find AddPortMapping? action!
13/05/13 23:36:57 ↓↓↓ 2 similar messages omitted ↓↓↓
13/05/13 23:36:47 ERROR [t Opener 261] net.i2p.router.transport.UPnP : Couldn't find AddPortMapping? action!
13/05/13 23:28:17 ↓↓↓ 4 similar messages omitted ↓↓↓
13/05/13 23:27:56 ERROR [t Opener 260] net.i2p.router.transport.UPnP : Couldn't find AddPortMapping? action!

Subtickets

Change History (5)

comment:1 Changed 6 years ago by zzz

  • Component changed from unspecified to router/transport
  • Owner set to zzz
  • Status changed from new to accepted

comment:2 Changed 6 years ago by zzz

Does this always happen, or does a restart fix it?

comment:3 Changed 6 years ago by guest

It stopped for 20 minutes then continued after restart.

comment:4 Changed 6 years ago by zzz

Then you have the strangest UPnP device ever, one that doesn't support port forwarding. All I can do is change the error to a warning so it doesn't fill up the logs.

comment:5 Changed 6 years ago by zzz

  • Resolution set to fixed
  • Status changed from accepted to closed

Fixed in 0.9.5-23-rc rev b6c0882b13ae465eb488ebaa07d577d2c355f8ee to change log level to warn, and log only once with a warning when the device lacking AddPortMapping? is detected.

Note: See TracTickets for help on using tickets.