Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#931 closed defect (not a bug)

UPnP.java documentation error(?)

Reported by: guest Owned by:
Priority: minor Milestone: 0.9.6
Component: router/transport Version: 0.9.5
Keywords: Cc:
Parent Tickets:

Description

\o.

Line 78 in router/java/src/net/i2p/router/transport/UPnP.java is:
" FIXME: detect it for real and deal with it! @see #2524"

As far as I can see, ticket #2524 in trac does not exist.

Subtickets

Change History (2)

comment:1 Changed 6 years ago by zzz

  • Component changed from unspecified to router/transport
  • Resolution set to not a bug
  • Status changed from new to closed

Thanks for the report.

Pretty sure that came in with the code which we took from freenet (and they took from limwire iirc), so it's one of their tickets.

In any case, while we are concerned about accurate javadocs, I don't think we want to start using trac tickets to manage inaccuracies in inline comments. They are simply unstructured, possibly historical, notes and they aren't maintained.

comment:2 Changed 6 years ago by zab

The writing style of the comment looks very familiar !!! :)

I don't remember the details after so many years but it could be referring to a line number and not a ticket number. We got the code from Azureus but this comment is definAtelly mine.

Note: See TracTickets for help on using tickets.