Opened 9 years ago

Closed 8 years ago

#95 closed defect (fixed)

UPnP Parser Exceptions

Reported by: anonymous Owned by: zzz
Priority: minor Milestone: 0.8.3
Component: router/transport Version: 0.8
Keywords: Cc:
Parent Tickets:

Description

I2P version: 0.8-0
Java version: Sun Microsystems Inc. 1.6.0_22 (Java(TM) SE Runtime Environment 1.6.0_22-b04)
Platform: Windows XP x86 5.1
Processor: uninitialized (pentium3)
Jbigi: Locally optimized native BigInteger? library loaded from the library path
Encoding: Cp1252

Berichte der Kritischen Ereignisse
Router Berichte (ändere)
Ort der Datei: C:\Programme\i2p\logs\log-router-0.txt

10:43:41.880 FEHLER [NotifySocket?] org.cybergarage.util.Debug : org.cybergarage.xml.ParserException?: java.net.SocketTimeoutException?: connect timed out at org.cybergarage.xml.Parser.parse(Parser.java:65) at org.cybergarage.upnp.ControlPoint?.addDevice(ControlPoint?.java:228) at org.cybergarage.upnp.ControlPoint?.notifyReceived(ControlPoint?.java:477) at org.cybergarage.upnp.ssdp.SSDPNotifySocket.run(SSDPNotifySocket.java:112) at java.lang.Thread.run(Unknown Source) Caused by: java.net.SocketTimeoutException?: connect timed out at java.net.PlainSocketImpl?.socketConnect(Native Method) at java.net.PlainSocketImpl?.doConnect(Unknown Source) at java.net.PlainSocketImpl?.connectToAddress(Unknown Source) at java.net.PlainSocketImpl?.connect(Unknown Source) at java.net.SocksSocketImpl?.connect(Unknown Source) at java.net.Socket.connect(Unknown Source) at sun.net.NetworkClient?.doConnect(Unknown Source) at sun.net.www.http.HttpClient?.openServer(Unknown Source) at sun.net.www.http.HttpClient?.openServer(Unknown Source) at sun.net.www.http.HttpClient?.(Unknown Source) at sun.net.www.http.HttpClient?.New(Unknown Source) at sun.net.www.http.HttpClient?.New(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection.plainConnect(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection.connect(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source) at org.cybergarage.xml.Parser.parse(Parser.java:55) ... 4 more
10:43:41.880 FEHLER [NotifySocket?] org.cybergarage.util.Debug : NOTIFY * HTTP/1.1 Host:239.255.255.250:1900 NT:upnp:rootdevice NTS:ssdp:alive Location:http://192.168.2.100:2869/upnphost/udhisapi.dll?content=uuid:a8420979-3a0b-4a21-ae28-37221416c0f5 USN:uuid:a8420979-3a0b-4a21-ae28-37221416c0f5::upnp:rootdevice Cache-Control:max-age=900 Server:Microsoft-Windows-NT/5.1 UPnP/1.0 UPnP-Device-Host/1.0 OPT:"http://schemas.upnp.org/upnp/1/0/"; ns=01 01-NLS:5b0902ae924b6316d1e8bf74fe5ac24c
10:43:38.864 FEHLER [NotifySocket?] org.cybergarage.util.Debug : org.cybergarage.xml.ParserException?: java.net.SocketTimeoutException?: connect timed out at org.cybergarage.xml.Parser.parse(Parser.java:65) at org.cybergarage.upnp.ControlPoint?.addDevice(ControlPoint?.java:228) at org.cybergarage.upnp.ControlPoint?.notifyReceived(ControlPoint?.java:477) at org.cybergarage.upnp.ssdp.SSDPNotifySocket.run(SSDPNotifySocket.java:112) at java.lang.Thread.run(Unknown Source) Caused by: java.net.SocketTimeoutException?: connect timed out at java.net.PlainSocketImpl?.socketConnect(Native Method) at java.net.PlainSocketImpl?.doConnect(Unknown Source) at java.net.PlainSocketImpl?.connectToAddress(Unknown Source) at java.net.PlainSocketImpl?.connect(Unknown Source) at java.net.SocksSocketImpl?.connect(Unknown Source) at java.net.Socket.connect(Unknown Source) at sun.net.NetworkClient?.doConnect(Unknown Source) at sun.net.www.http.HttpClient?.openServer(Unknown Source) at sun.net.www.http.HttpClient?.openServer(Unknown Source) at sun.net.www.http.HttpClient?.(Unknown Source) at sun.net.www.http.HttpClient?.New(Unknown Source) at sun.net.www.http.HttpClient?.New(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection.plainConnect(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection.connect(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source) at org.cybergarage.xml.Parser.parse(Parser.java:55) ... 4 more
10:43:38.864 FEHLER [NotifySocket?] org.cybergarage.util.Debug : NOTIFY * HTTP/1.1 Host:239.255.255.250:1900 NT:upnp:rootdevice NTS:ssdp:alive Location:http://192.168.2.100:2869/upnphost/udhisapi.dll?content=uuid:a8420979-3a0b-4a21-ae28-37221416c0f5 USN:uuid:a8420979-3a0b-4a21-ae28-37221416c0f5::upnp:rootdevice Cache-Control:max-age=900 Server:Microsoft-Windows-NT/5.1 UPnP/1.0 UPnP-Device-Host/1.0 OPT:"http://schemas.upnp.org/upnp/1/0/"; ns=01 01-NLS:5b0902ae924b6316d1e8bf74fe5ac24c
10:43:35.864 FEHLER [NotifySocket?] org.cybergarage.util.Debug : org.cybergarage.xml.ParserException?: java.net.SocketTimeoutException?: connect timed out at org.cybergarage.xml.Parser.parse(Parser.java:65) at org.cybergarage.upnp.ControlPoint?.addDevice(ControlPoint?.java:228) at org.cybergarage.upnp.ControlPoint?.notifyReceived(ControlPoint?.java:477) at org.cybergarage.upnp.ssdp.SSDPNotifySocket.run(SSDPNotifySocket.java:112) at java.lang.Thread.run(Unknown Source) Caused by: java.net.SocketTimeoutException?: connect timed out at java.net.PlainSocketImpl?.socketConnect(Native Method) at java.net.PlainSocketImpl?.doConnect(Unknown Source) at java.net.PlainSocketImpl?.connectToAddress(Unknown Source) at java.net.PlainSocketImpl?.connect(Unknown Source) at java.net.SocksSocketImpl?.connect(Unknown Source) at java.net.Socket.connect(Unknown Source) at sun.net.NetworkClient?.doConnect(Unknown Source) at sun.net.www.http.HttpClient?.openServer(Unknown Source) at sun.net.www.http.HttpClient?.openServer(Unknown Source) at sun.net.www.http.HttpClient?.(Unknown Source) at sun.net.www.http.HttpClient?.New(Unknown Source) at sun.net.www.http.HttpClient?.New(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection.getNewHttpClient(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection.plainConnect(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection.connect(Unknown Source) at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source) at org.cybergarage.xml.Parser.parse(Parser.java:55) ... 4 more
10:43:35.864 FEHLER [NotifySocket?] org.cybergarage.util.Debug : NOTIFY * HTTP/1.1 Host:239.255.255.250:1900 NT:upnp:rootdevice NTS:ssdp:alive Location:http://192.168.2.100:2869/upnphost/udhisapi.dll?content=uuid:a8420979-3a0b-4a21-ae28-37221416c0f5 USN:uuid:a8420979-3a0b-4a21-ae28-37221416c0f5::upnp:rootdevice Cache-Control:max-age=900 Server:Microsoft-Windows-NT/5.1 UPnP/1.0 UPnP-Device-Host/1.0 OPT:"http://schemas.upnp.org/upnp/1/0/"; ns=01 01-NLS:5b0902ae924b6316d1e8bf74fe5ac24c
05:02:11.213 FEHLER [cheduler 1/4] net.i2p.util.ByteCache? : WARNING: Low memory, clearing byte caches
22:56:20.291 FEHLER [cheduler 3/4] net.i2p.util.ByteCache? : WARNING: Low memory, clearing byte caches
21:30:31.568 FEHLER [JobQueue2 ] router.tunnel.TunnelDispatcher?: no matching outbound tunnel for id=3206320378: existing = 10 java.lang.Exception: src at net.i2p.router.tunnel.TunnelDispatcher?.dispatchOutbound(TunnelDispatcher?.java:495) at net.i2p.router.tunnel.pool.TestJob?.sendTest(TestJob?.java:160) at net.i2p.router.tunnel.pool.TestJob?.runJob(TestJob?.java:112) at net.i2p.router.JobQueueRunner?.runCurrentJob(JobQueueRunner?.java:145) at net.i2p.router.JobQueueRunner?.run(JobQueueRunner?.java:85) at java.lang.Thread.run(Unknown Source) at net.i2p.util.I2PThread.run(I2PThread.java:77)

Subtickets

Change History (3)

comment:1 Changed 9 years ago by zzz

  • Component changed from api/data to router/transport
  • Owner set to zzz
  • Priority changed from major to minor
  • Status changed from new to assigned

These are harmless UPnP errors, they need to be hidden from the logs and changed to warnings

comment:2 Changed 9 years ago by zzz

  • Summary changed from 0.8 bugs to UPnP Parser Exceptions

comment:3 Changed 8 years ago by zzz

  • Milestone set to 0.8.3
  • Resolution set to fixed
  • Status changed from assigned to closed
  • Version set to 0.8

All UPnP errors changed to warnings in 0.8.3

Note: See TracTickets for help on using tickets.