Opened 6 years ago

Closed 4 years ago

#950 closed defect (fixed)

Imule & SAM, net.i2p.sam.SAMv3Handler : Unexpected exception for message

Reported by: guest Owned by: mkvore
Priority: minor Milestone:
Component: other Version: 0.9.6
Keywords: Imule Cc: zab@…
Parent Tickets:

Description

09.06.13 15:12:52 ↓↓↓ 2 similar messages omitted ↓↓↓
09.06.13 15:12:52 FEHLER [v3Handler 26] net.i2p.sam.SAMv3Handler : Unexpected exception for message [STREAM CONNECT ID=iMule_oPw2pQT-AL DESTINATION=]

java.lang.StringIndexOutOfBoundsException?: String index out of range: 0
at java.lang.AbstractStringBuilder?.charAt(AbstractStringBuilder?.java:205)
at java.lang.StringBuilder?.charAt(StringBuilder?.java:72)
at net.i2p.sam.SAMUtils.parseParams(SAMUtils.java:169)
at net.i2p.sam.SAMv3Handler.handle(SAMv3Handler.java:382)
at net.i2p.sam.SAMHandler.run(SAMHandler.java:190)
at java.lang.Thread.run(Thread.java:722)
at net.i2p.util.I2PThread.run(I2PThread.java:85)

Subtickets

Change History (8)

comment:1 Changed 6 years ago by zab

  • Cc zab@… added
  • Owner changed from mkvore to zab
  • Status changed from new to accepted

comment:2 Changed 6 years ago by zab

How reproducible is this? Looks like iMule is sending malformed input like

key1=value1 key2= 

where value2 is missing or an empty string.

If you can reproduce this easily, please enable DEBUG logging for net.i2p.sam.SAMv3Handler so we can track down exactly what the problematic input is. (This may affect your anonymity somewhat)

comment:3 Changed 6 years ago by zzz

I2P and iMule versions please

Ah, the missing value is right in the OP.

[STREAM CONNECT ID=iMule_oPw2pQT-AL DESTINATION=]

How did that happen?

comment:4 Changed 6 years ago by guest

Hi get this Problem from time to time

IMule:2.3.2.2 (run on a diffrent PC)

I2P version: 0.9.6-0
Java version: Oracle Corporation 1.8.0-ea (Java(TM) SE Runtime Environment 1.8.0-ea-b36e)
Wrapper version: 3.5.15
Server version: 7.6.10.v20130312
Servlet version: Jasper JSP 2.1 Engine
Platform: Linux arm 3.6.11+
Processor: uninitialized (arm)
Jbigi: Native BigInteger? library libjbigi-linux-armv6.so loaded from resource
Encoding: UTF-8
Charset: UTF-8

comment:5 Changed 6 years ago by zab

  • Milestone 0.9.7 deleted
  • Owner changed from zab to mkvore
  • Status changed from accepted to assigned

I added an explicit check for empty values with revision 1f5fbd0bad971c530712ec233063ee8b64f88f5f

Handing the ticket back to mkvore for debugging on the iMule side.

comment:6 Changed 5 years ago by ExtraBattery

Add a subticket #1325.

comment:7 Changed 4 years ago by zzz

Remove a subticket #1325.

comment:8 Changed 4 years ago by zzz

  • Component changed from apps/SAM to other
  • Resolution set to fixed
  • Status changed from assigned to closed

removed as parent of #1325 so we can close this one eventually. Any remaining issue is on the iMule side.

Note: See TracTickets for help on using tickets.