Opened 6 years ago

Closed 6 years ago

#962 closed enhancement (not a bug)

Feature request: changing keys (aka desthash + private key) by request

Reported by: DISABLED Owned by:
Priority: trivial Milestone: 0.9.7
Component: apps/i2ptunnel Version: 0.9.6
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

For now, it can be made by using router.dynamickeys=true and restarting. (Though i am not so sure, your documentation on configs is sooo much bad, incomplete, separated and sometimes difficult to understand without looking into the sources)
But sometimes there are eepsites that poorly block clients thinking that they are do ddos after just a few requests. Postman hq, for example, does that, when you are guessing which password from many is used.
That would also be useful for some privacy concerns.

Should look like just a little button in routerconsole named like "change your desthash"

The best solution however would be a system that can manage multiple keys (you won't lose your awesome netdb-integration, hooray!) - but that requires more time. Though, java isn't that time-hungry in terms of programming, judging by people that give speed and lack of VM in exchange of… something except speed.

Subtickets

Change History (4)

comment:1 Changed 6 years ago by DISABLED

Strange thing that they do not block users depending on the current load of server… Thus, they are poor, it takes 5 minutes to implement that.

comment:2 Changed 6 years ago by Eche|on

Moin

Which destination hash would you like to change?
Router key? Router ID?
Destination address of eepsite-servers?
Destination hash of a client?

The big eepsites do block based on accesses independent of client hash.
If you want your source hash to be changed, stop the client tunnel, wait 11 minutes, start it again.
Even a button on the console would do the same.

echelon

comment:3 Changed 6 years ago by zzz

Component: apps/consoleapps/i2ptunnel

Right. You've confused router keys and client (destination) keys. They are unrelated, of course (that would be bad for anonymity).

Changing router keys does nothing for the blocking you describe. It also does nothing for anonymity, unless you are also changing your IP. To change router keys automatically when you change IP, there's 'laptop mode' on the network configuration page.

The ops for several popular eepsites have learned how to defend against attacks and out-of-control spiders. Some blocks depend on client hash, some don't.

For client tunnels, there's a 'close tunnels on idle' and 'new keys on reopen' check boxes that will do what you want.

But for server blocking that you think is too aggressive, it's probably better to discuss that with the eepsite owner, not come up with schemes to circumvent it.

comment:4 Changed 6 years ago by zzz

Resolution: not a bug
Status: newclosed
Note: See TracTickets for help on using tickets.