Opened 6 years ago

Closed 2 years ago

#968 closed defect (fixed)

Persistent private key overwritten

Reported by: guest Owned by:
Priority: minor Milestone: 0.9.25
Component: apps/i2ptunnel Version: 0.9.6
Keywords: regression Cc: kytv
Parent Tickets:

Description

I am running a service (IRC) with whitelist enforced. I am encountering this problem with some of my users. I know the release is coming up so I did not want to delay reporting it in hopes of a fix before that.

This has happened 4-5 times, I am unable to isolate any specifics to reproduce it each time.

With persistent private keys set (but no filename specified), on connect, tunnels seem to duplicate and generate new local destinations. A new key destination appears after each disconnect/connect - as you can imagine, this is problematic for a whitelisted destination.

The tunnel name appears several times in the left sidebar "local destinations". Changing to a filename of my choosing keeps the same tunnel and local dest. Seems to be reproducable on Windows 8 32-bit and Mac OS X 10.x PPC with latest I2P (0.9.6).

Tunnel settings:

Auto start
Profile: interactive
Delay connect
Reduce tunnel quantity
Close tunnels when idle
Delay tunnel open until required
Persistent private key

Resolving this is possible by stopping the tunnel, restarting I2P, choosing a new file name and starting the tunnel.

Subtickets

Change History (6)

comment:1 Changed 6 years ago by zzz

  • Component changed from unspecified to apps/i2ptunnel
  • Milestone changed from 0.9.7 to 0.9.8

comment:2 follow-up: Changed 6 years ago by zzz

may be because another tunnel gets the same default name? shouldn't though. But default name tied to tunnel number, and tunnel number can change if a lower-numbered tunnel is deleted. But default name should get saved. I remember trying to fix this a couple years back but maybe still needs more work. Maybe the fixes were on the server side and didn't apply to persistent clients.

To be researched.

In the meantime please recommend to your users that they specify a filename and not use the default.

comment:3 in reply to: ↑ 2 Changed 6 years ago by guest

Replying to zzz:

may be because another tunnel gets the same default name? shouldn't though. But default name tied to tunnel number, and tunnel number can change if a lower-numbered tunnel is deleted. But default name should get saved. I remember trying to fix this a couple years back but maybe still needs more work. Maybe the fixes were on the server side and didn't apply to persistent clients.

To be researched.

In the meantime please recommend to your users that they specify a filename and not use the default.

IIRC, it is happening when a name is set. I'll recommend that.

comment:4 Changed 4 years ago by str4d

  • Keywords regression added
  • Milestone 0.9.8 deleted

comment:5 Changed 4 years ago by killyourtv

  • Cc kytv added

comment:6 Changed 2 years ago by zzz

  • Milestone set to 0.9.25
  • Resolution set to fixed
  • Status changed from new to closed

related: #1628 which was fixed in 0.9.25. That ticket is for files with default names. OP says it's for a client tunnel (persistent private keys) without a filename specified. But the form defaults to have a name in the field. Maybe that changed along the way since this ticket was filed, not sure. Comment 3 says "it is happening when a name is set", not sure if that means the bug is happening or it's working.

Can't reproduce. Declaring fixed by #1628 in 0.9.25.

Note: See TracTickets for help on using tickets.