Opened 6 years ago

Closed 6 years ago

#970 closed enhancement (not a bug)

/configpeer add ban reason table

Reported by: DISABLED Owned by:
Priority: trivial Milestone: 0.9.9
Component: apps/console Version: 0.9.6
Keywords: Cc:
Parent Tickets: Sensitive: no

Description

It might be information to allow for a ban reason in the configpeer page. There are alot of ip's banned by default with no notion of why.

Subtickets

Change History (2)

comment:1 Changed 6 years ago by zzz

Milestone: 0.9.70.9.9
Priority: minortrivial

You mean the "IPs permanently banned" or the "IPs banned until restart" section?

The permanent ban file (~/.i2p/blocklist.txt) does have reasons in it - and those reasons will be copied to the "banned peers" section if any peer is encountered from that IP range.

The vast majority of blocklist.txt is just bogons.

We don't bring the reason string from the file, just to save a little memory. The default blocklist is short but the blocklist subsystem was designed to handle huge blocklists like the ones from bluetack, that's why we don't bring the reason string in.

comment:2 Changed 6 years ago by DISABLED

Resolution: not a bug
Status: newclosed

Ok this makes sense.
Thank you for responding zzz

Note: See TracTickets for help on using tickets.