Opened 6 years ago

Closed 6 years ago

#975 closed defect (worksforme)

Not forwarding cookies keeps some websites from working

Reported by: Lerianis Owned by:
Priority: minor Milestone:
Component: apps/i2ptunnel Version: 0.9.6
Keywords: Cc: echelon
Parent Tickets:

Description

There is an issue where not forwarding cookies like one person informed me that i2p does keeps some websites from working, mainly various forum websites that use VBulletin.
I have no idea why this is because some websites work while others do not work.

Subtickets

Change History (4)

comment:1 Changed 6 years ago by zzz

  • Component changed from www to apps/i2ptunnel
  • Milestone 0.9.7 deleted

We certainly do forward cookies, no matter what "one person" said. trac uses cookies, for example, so if you logged in here, cookies are working. The only thing we block is b32.i2p "supercookies". If you can isolate it to a particular cookie or format, please add the details to the ticket and we can investigate further. You haven't given us enough info to do anything with.

comment:2 Changed 6 years ago by Lerianis

I am sorry to report that yes, i2p does block cookies. There are some porn websites that use cookies (not super-cookies, just basic cookies akin to what CNN and Disqus use for their log-ins) like e-hentai.org which are having their cookies blocked by i2p for some reason or not forwarded correctly.

The Hentai-Foundry (another porn website) also has the issue where their cookie is being blocked for some reason by i2p.

I've talked with the site creators/webmasters and they have said in both cases that the sites just use regular old cookies and not supercookies.

I didn't want to go into specifics on this issue because, obviously.... porn websites. A little touchy subject for some people in the least.

comment:3 Changed 6 years ago by zzz

  • Cc echelon added

oh, you're talking *external* websites via the outproxy? Maybe the outproxy is doing it. Adding echelon to cc. You may also wish to contact him directly to continue the discussion.

comment:4 Changed 6 years ago by zzz

  • Resolution set to worksforme
  • Status changed from new to closed

Closing on the assumption that this is an issue with an outproxy. If you have any evidence that this is caused by I2P itself, please reopen.

Note: See TracTickets for help on using tickets.