Opened 6 years ago

Closed 6 years ago

#982 closed defect (not a bug)

Peers used in the same order twice in a tunnel

Reported by: guest Owned by:
Priority: minor Milestone:
Component: router/general Version: 0.9.7
Keywords: Cc:
Parent Tickets:

Description

This may be desired/proper behavior but I do not feel comfortable with it: I noticed peers being used many times within the same tunnel group and, at times, being used in the same order above/below each other.

Surely peers should not be relied upon this much?

Subtickets

Change History (1)

comment:1 Changed 6 years ago by zzz

  • Component changed from unspecified to router/general
  • Milestone 0.9.8 deleted
  • Resolution set to not a bug
  • Status changed from new to closed

Yes it's on purpose. Read about it in our docs or research "predecessor attack".

In the future, please come to IRC #i2p or #i2p-dev if you have questions or are not "comfortable" rather than opening a ticket.

Note: See TracTickets for help on using tickets.