Opened 5 years ago

Closed 5 years ago

#995 closed defect (fixed)

NotImplementedError:

Reported by: Ovoxyba Owned by: welterde
Priority: minor Milestone:
Component: trac Version:
Keywords: Cc:
Parent Tickets:

Description

How to Reproduce

While doing a GET operation on /changeset, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'format': u'diff', 'new': u'325a9ed6f0f47eeabb33710073edf973671c63c9'}

System Information

Trac 0.11.7
Python 2.6.6 (r266:84292, Dec 26 2010, 22:31:48)
[GCC 4.4.5]
setuptools 0.6
SQLite 3.7.3
pysqlite 2.6.0
Genshi 0.6
Pygments 1.3.1
Monotone interface: 12.1

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/trac/web/main.py", line 450, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.6/dist-packages/trac/web/main.py", line 206, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.6/dist-packages/trac/versioncontrol/web_ui/changeset.py", line 316, in process_request
    self._render_diff(req, filename, repos, data)
  File "/usr/lib/python2.6/dist-packages/trac/versioncontrol/web_ui/changeset.py", line 646, in _render_diff
    old_path=data['old_path'], old_rev=data['old_rev']):
  File "build/bdist.linux-x86_64/egg/tracmtn/backend.py", line 489, in get_changes
    raise NotImplementedError
NotImplementedError


Subtickets

Change History (8)

comment:1 Changed 5 years ago by zzz

  • Component changed from unspecified to trac
  • Milestone 0.9.8 deleted
  • Owner set to welterde
  • Status changed from new to assigned
  • Version 0.9.7 deleted

comment:2 Changed 5 years ago by guest

  • Resolution set to worksforme
  • Status changed from assigned to closed

comment:3 Changed 5 years ago by str4d

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:4 Changed 5 years ago by guest

  • Resolution set to wontfix
  • Status changed from reopened to closed

comment:5 Changed 5 years ago by str4d

  • Resolution wontfix deleted
  • Status changed from closed to reopened

comment:6 Changed 5 years ago by killyourtv

  • Resolution set to wontfix
  • Status changed from reopened to closed

Since the Trac-Monotone plugin was disabled due to instability issues, /changeset will not exist anymore.

Closing as WONTFIX since the Monotone integration is unsupported upstream.

comment:7 Changed 5 years ago by killyourtv

  • Resolution wontfix deleted
  • Status changed from closed to reopened

comment:8 Changed 5 years ago by killyourtv

  • Resolution set to fixed
  • Status changed from reopened to closed

I think this is a good resolution:

Since we no longer have Trac-Monotone installed---and haven't had it installed for several months---some of the links in our documentation were broken. The web site has been changed to point to github but I thought redirecting from the old locations within Trac to github would be better instead of sending 410 Gone. Within I2P I'm redirecting to my ViewMTN installation.

If a user is accessing Trac from the Internet via an In-Proxy I redirect them to https://trac.i2p2.de.

Links to /changeset are gone and won't be coming back, at least not while we're still using Monotone and Trac-Monotone is dysfunctional. But some of the links provided by Trac-Monotone are being redirected--temporarily at least:

Internet

RewriteRule /browser/Makefile\.gcj https://github.com/i2p/i2p.i2p/tree/master/Makefile.gcj [R=301,L,NC]
RewriteRule ^/browser/core/java/src/net/i2p/crypto/(.+)\.java.* https://github.com/i2p/i2p.i2p/tree/master/core/java/src/net/i2p/crypto/$1.java [R=301,L,NC]
RewriteRule ^/browser/plugin/makeplugin\.sh.* https://github.com/i2p/i2p.scripts/tree/master/plugin/makeplugin.sh [R=301,L,NC]

RewriteCond %{SERVER_PORT} !^443$
RewriteRule (.*) https://trac.i2p2.de$1  [NC,R=301,L]

Within I2P

RewriteCond %{HTTP:X-Forwarded-For} .+ [OR]
RewriteCond %{HTTP:X-Forwarded-Server} .+
RewriteRule /browser/Makefile\.gcj https://github.com/i2p/i2p.i2p/tree/master/Makefile.gcj [R=301,L,NC]

RewriteCond %{HTTP:X-Forwarded-For} .+ [OR]
RewriteCond %{HTTP:X-Forwarded-Server} .+
RewriteRule ^/browser/core/java/src/net/i2p/crypto/(.+)\.java.* https://github.com/i2p/i2p.i2p/tree/master/core/java/src/net/i2p/crypto/$1.java [R=301,L,NC]

RewriteCond %{HTTP:X-Forwarded-For} .+ [OR]
RewriteCond %{HTTP:X-Forwarded-Server} .+
RewriteRule ^/browser/plugin/makeplugin\.sh.* https://github.com/i2p/i2p.scripts/tree/master/plugin/makeplugin.sh [R=301,L,NC]

RewriteCond %{HTTP:X-Forwarded-For} .+ [OR]
RewriteCond %{HTTP:X-Forwarded-Server} .+
RewriteRule (.*) https://trac.i2p2.de$1 [R=301,L,NC]

RewriteRule ^/browser/Makefile\.gcj http://killyourtv.i2p/viewmtn/branch/head/file/i2p.i2p/Makefile.gcj [R=301,L,NC]
RewriteRule ^/browser/core/java/src/net/i2p/crypto/(.+)\.java.* http://killyourtv.i2p/viewmtn/branch/head/file/i2p.i2p/core/java/src/net/i2p/crypto/$1.java [R=301,L,NC]
RewriteRule ^/browser/plugin/makeplugin\.sh.* http://killyourtv.i2p/viewmtn/branch/head/file/i2p.scripts/plugin/makeplugin.sh  [R=301,L,NC]

Both Internally and Externally

RewriteRule ^/browser/ - [G]
RewriteRule ^/changeset/ - [G]
RewriteRule ^/diff/ - [G]
RewriteRule ^/export/ - [G]
RewriteRule ^/log/ - [G]

Closing as fixed.

Note: See TracTickets for help on using tickets.