Changes between Version 6 and Version 7 of Crypto/ECDSA


Ignore:
Timestamp:
Nov 27, 2014 1:37:46 PM (5 years ago)
Author:
zzz
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • Crypto/ECDSA

    v6 v7  
    2020There are several possible reasons for the lack of ECDSA support:
    2121
    22 - Red Hat / Fedora OSes: Not supported. Install the Bouncy Castle provider "bcprov" jar. Instructions: http://forum.i2p/viewtopic.php?t=11580
     22- Red Hat / Fedora OSes: Not supported. Install the Bouncy Castle provider "bcprov" jar. Instructions below or at: http://forum.i2p/viewtopic.php?t=11580
    2323- Old version of I2P. ECDSA support was added in 0.9.12. We recommend that you upgrade to the current release.
    2424- Old version of Java. If you are running Java 6, try upgrading to Java 7.
     
    2626- Old or unusual OS without ECDSA support. See Red Hat above.
    2727
     28== Bouncy Castle Provider Installation Instructions ==
    2829
     30- Stop I2P
     31- Download the provider jar from https://www.bouncycastle.org/download/bcprov-jdk15on-151.jar
     32- Find your I2P Installation directory. This is usually at $HOME/i2p on Linux, but it varies if installed as a service.
     33- Copy the bcprov-jdk15on-151.jar file to the lib/ directory inside your installation directory.
     34- Start I2P
    2935
    3036