Changes between Version 27 and Version 28 of java


Ignore:
Timestamp:
May 9, 2014 9:45:43 AM (5 years ago)
Author:
killyourtv
Comment:

Legend:

Unmodified
Added
Removed
Modified
  • java

    v27 v28  
    44
    55|| '''JRE/SDK''' || '''Works''' || '''Compiles''' || '''Performance''' ||
    6 || Oracle/Sun 5 || yes || yes || good
     6|| Oracle/Sun 5 || no || no || I2P 0.9.12 and newer requires Java 1.6 or newer
    77|| Oracle/Sun 6 || yes || yes || good
    88|| Oracle/Sun 7 || yes || yes || good
    9 || GCJ (compiled to C)|| yes || all but console || very poor
    10 || GCJ-JRE (gij-4.4)|| yes || yes for I2P releases through 0.8, if you supply the Pack200 jar - see note below || poor, not recommended
    11 || Iced Tea 5 || || ||
     9|| GCJ (compiled to C)|| no || no || very poor
     10|| GCJ-JRE (gij-4.4)|| no || I2P 0.9.12 and newer requires Java 1.6 or newer
     11|| Iced Tea 5 || no ||no || I2P 0.9.12 and newer requires Java 1.6 or newer
    1212|| Iced Tea 6 || yes || yes (no on PPC "1.6.0_18" OpenJDK Runtime Environment (IcedTea6 1.8) - missing Pack200 - see http://forum.i2p/viewtopic.php?t=4655 ) - see note below || good
    1313|| Iced Tea 7 || yes || yes || good
    14 || Open JDK 5 || || || 
     14|| Open JDK 5 || no || no ||  I2P 0.9.12 and newer requires Java 1.6 or newer
    1515|| Open JDK 6 || yes || yes || good
    16 || Open JDK 7 || yes || yes || good, except on Raspberry Pi (use [https://jdk8.java.net/download.html Java8 Early Access] on the Pi) 
     16|| Open JDK 7 || yes || yes || good, except on Raspberry Pi (use [https://jdk8.java.net
     17/download.html Java8 Early Access] on the Pi) 
     18|| Open JDK 8 || yes || yes || good
    1719|| IBM || Reportedly does not http://zzz.i2p/topics/577 || ||
    1820|| Android || yes || yes (core and router) || poor/OK depending on hardware; 512 MB RAM recommended
     
    3638-------
    3739
    38 Note that as of I2P release 0.8.1, a 1.6 or higher compatible SDK is required to compile I2P. 1.5 or higher compatible JRE is still required to run I2P.
    39 
    40 -------
    41 
    42 Pack200 note: You can get a free version of pack200.jar from the Apache Harmony package; if you install the Harmony SDK on Ubuntu, the file will be at /usr/lib/harmony-5.0/jdk/jre/lib/boot/pack200.jar; copy it to your JRE's library directory.
    43 
    44 Update: As of I2P release 0.8.3, I2P will use either the Sun or Apache Pack200 if it is in the classpath at runtime, and neither is required to compile I2P.
     40As of I2P 0.9.12, a 1.6 compatible SDK is required to compile I2P. A 1.6 or higher JRE is required to run I2P.